Alpha & Omega Rentals: Not A Happy Experience…

So, I stopped by Alpha & Omega Rentals outside Belfair, Wa last week and arranged for an excavator to be delivered out to the property at 0800 Monday morning. Monday morning comes around and I get up at 0600 and out of the house by 0700. Get out to the property about 0745 and wait until 0900 for it to show up. I drove a couple of miles down the road (towards town) until I could get a signal on the cell phone and called them. “Oh, the manager didn’t update the board so I didn’t know if it was today or next Monday.” Says the person that answered. Said he’d be right out. He shows up at 1015 or so. By the time it’s unloaded I’m starting 2 1/2 hours late. The guy that dropped the excavator off did offer to pick it up Tuesday morning so I could have the rest of the day to work. Cool.

Filled in the trench we made for the power/water lines and dug from the end of that trench to the road. Didn’t cross the road ’cause I still need to drive up and down it. Re-dug the drainage ditch in the dome hole and moved some things around. Stuffed a tree-stump into that hole that keeps appearing in the road. Worked until about 1700.

Got up at 0600 again this morning, out of the house by 0715 and out at the property by 0800. Decided to do some work while waiting for the guy to come and pick up the excavator. An hour goes by so I drive down the road for a cell-signal, call them and the girl that answered says “OK.”. Back to the property. Another hour goes by. And another hour goes by. Finally at 1200 I park the excavator in the driveway opening, lock the gate and take off for their office.

Told the guy behind the desk that I got tired of waiting and that the excavator was sitting in my driveway with a full tank of gas and the key still in it. He immediately got surly (that really is the only way to describe his demeanor) and spouted half a dozen excuses on why it hasn’t been picked up yet. I said that I thought 3 hours was plenty long enough to wait and he came back with more whining and passing the buck. I signed my receipt ($290!!) and left.

Like I said. Not A Happy Experience. I will try my best NOT to rent from them again.

The Excavator I RentedExcavator I Rented.

Here’s the excavator I rented. Worked okay but it took some getting used to having the claw switch under my right foot.

Save pagePDF pageEmail pagePrint page

I Am Learning WAY Too Much About Dozer Mechanics!

Got up yesterday and took my ‘crowd cylinder’ (from atop the boom on the backhoe) to Pape (pronounced Pa Pay) over in Fife. Asked them if it would be okay for me to watch them replace the seals. Man, am I ever glad I took it over to them to fix!!! I’d have never gotten it done at home. Alone. We had to use a 5-ton crane and a lot of muscle to get the ram out of the cylinder! I got right in there with the young guy that was changing the seals and got just as dirty and tired. Guess I was some help cause they didn’t charge me for the job. Cool! We figured out I have a JD 350-D dozer. The ‘D’s stands for “Dey Don’t Make No More Parts For Dis One!”.

Left Fife at 1400 and zoomed to our property to meet the hydroseeding guy. Almost missed him. Showed him what we need hydroseeded but he thinks the job might be a bit too much for him; so he gave me a card with another company’s information on it. Was raining pretty good out there and we were soaked by the time we walked from the bottom of the hill to the top and back. Nice guy though.

Got up today and went and picked up my radiator. $700! Phew! I spent ALL DAY putting my dozer back together. Went fairly easy¬ but MESSY! Even the front of the dozer went back on without much trouble. Lifting that 100lb cylinder back to the top of the boom was a bitch though! But after that it hooked back in quickly. Bled the air out by flooding one side (completely retracting the ram), hooking up the bottom side and unhooking the top side and filling it from the bottom until hydrolic fluid started coming out of the top. Then rehooked up the top side. Works great and NO leaks!

Radiator went in fairly easily. Ran the dozer for about 15 minutes for it to get warm. Had one small leak where I didn’t tighten down the¬ hose completely but once I tightened it up i had NO leaks! Cool! Managed to tighten up one of the tracks but can’t get grease to go into the other.

Will have to finish this later; SWMBO wants me to reboot the internet server….

Save pagePDF pageEmail pagePrint page